summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke T. Shumaker <lukeshu@parabola.nu>2024-02-21 10:14:41 -0700
committerLuke T. Shumaker <lukeshu@parabola.nu>2024-02-21 10:18:52 -0700
commita623a620f68ba19750fc4feba34d1d2db8cd08dc (patch)
tree670726f2fdeb99cdb99c917d2227580c4eb2ceb7
parentd7af69d13c9d9d64328de31055ca43ab63b25803 (diff)
fix: librefetch: Use the specified compression
-rwxr-xr-xsrc/librefetch/librefetch1
-rw-r--r--src/librefetch/librefetchdir/Makefile4
2 files changed, 3 insertions, 2 deletions
diff --git a/src/librefetch/librefetch b/src/librefetch/librefetch
index 8a62621..9b04837 100755
--- a/src/librefetch/librefetch
+++ b/src/librefetch/librefetch
@@ -222,6 +222,7 @@ doit() {
mv -f "$base_dst" "$dst"
fi
else
+ export PKGEXT=${base_dst##*/} # so the file uses the correct compression
export PKGDEST=${dst%/*}
export pkg_file=$dst
diff --git a/src/librefetch/librefetchdir/Makefile b/src/librefetch/librefetchdir/Makefile
index 4391efb..ed7b510 100644
--- a/src/librefetch/librefetchdir/Makefile
+++ b/src/librefetch/librefetchdir/Makefile
@@ -2,7 +2,7 @@
# note: This file is part of LibreFetch itself, not part of the
# build-system.
#
-# Copyright (C) 2016 Luke Shumaker <lukeshu@parabola.nu>
+# Copyright (C) 2016, 2024 Luke Shumaker <lukeshu@parabola.nu>
#
# License: GNU GPLv3+
#
@@ -31,7 +31,7 @@ new_makepkg = $(new)/makepkg
new_library = $(new)/libmakepkg
targets += $(new_makepkg)
-targets += $(patsubst $(old_library)/%,$(new_library)/%,$(shell find $(old_library) -type f))
+targets += $(patsubst $(old_library)/%,$(new_library)/%,$(shell find $(old_library) -type f -not -name ext.sh))
targets += $(new_library)/tidy/~source_date_epoch.sh
all: $(targets)