summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke T. Shumaker <lukeshu@parabola.nu>2024-02-21 18:12:11 -0700
committerLuke T. Shumaker <lukeshu@parabola.nu>2024-02-21 19:27:19 -0700
commitc1920ba5e8888b28d45b74890bd685e916433fd5 (patch)
tree594138fd1538ac32e8d64a908e6523f78887c570
parentcf8d398989e306e54a17018131de15a83ec1145f (diff)
build-sys: Add a config.mk:enable_manpages config knob
-rw-r--r--INSTALL5
-rw-r--r--build-aux/Makefile.each.head/20-libretools.mk2
-rw-r--r--build-aux/Makefile.each.tail/20-libretools.mk17
-rw-r--r--config.mk2
4 files changed, 15 insertions, 11 deletions
diff --git a/INSTALL b/INSTALL
index adef998..024dda6 100644
--- a/INSTALL
+++ b/INSTALL
@@ -28,8 +28,9 @@ The "unusual" build-time dependencies are:
purpose.
- ronn -- A markdown-to-manpage converter
-At this time, the build system does not support not building the
-documentation; ronn is required.
+Whether or not to build the manpages is controlled by whether
+config.mk:enable_manpages is empty (disable) or non-empty (enable).
+If it is disabled, then `ronn` is not needed.
Additionally, other usual "core utilities" are required:
diff --git a/build-aux/Makefile.each.head/20-libretools.mk b/build-aux/Makefile.each.head/20-libretools.mk
index 22f59ba..7a5e754 100644
--- a/build-aux/Makefile.each.head/20-libretools.mk
+++ b/build-aux/Makefile.each.head/20-libretools.mk
@@ -30,7 +30,7 @@ libretools.out.libs = $(libretools.src.sh)
libretools.out.docs = $(libretools.src.md)
libretools.out.confs = $(libretools.src.conf)
-libretools.out = $(libretools.out.mans)
+libretools.out = $(if $(enable_manpages),$(libretools.out.mans))
libretools.out += $(libretools.out.bins)
libretools.out += $(libretools.out.libexecs)
libretools.out += $(libretools.out.libs)
diff --git a/build-aux/Makefile.each.tail/20-libretools.mk b/build-aux/Makefile.each.tail/20-libretools.mk
index 3e54614..5000114 100644
--- a/build-aux/Makefile.each.tail/20-libretools.mk
+++ b/build-aux/Makefile.each.tail/20-libretools.mk
@@ -30,14 +30,15 @@ files.sys.$(libretools.pkg) += \
$(addprefix $(pkglibdir)/,$(libretools.out.libs)) \
$(addprefix $(pkglibexecdir)/,$(libretools.out.libexecs)) \
$(addprefix $(docdir)/,$(libretools.out.docs)) \
- $(addprefix $(mandir)/man1/,$(filter %.1,$(libretools.out.mans))) \
- $(addprefix $(mandir)/man2/,$(filter %.2,$(libretools.out.mans))) \
- $(addprefix $(mandir)/man3/,$(filter %.3,$(libretools.out.mans))) \
- $(addprefix $(mandir)/man4/,$(filter %.4,$(libretools.out.mans))) \
- $(addprefix $(mandir)/man5/,$(filter %.5,$(libretools.out.mans))) \
- $(addprefix $(mandir)/man6/,$(filter %.6,$(libretools.out.mans))) \
- $(addprefix $(mandir)/man7/,$(filter %.7,$(libretools.out.mans))) \
- $(addprefix $(mandir)/man8/,$(filter %.8,$(libretools.out.mans)))
+ $(if $(enable_manpages), \
+ $(addprefix $(mandir)/man1/,$(filter %.1,$(libretools.out.mans))) \
+ $(addprefix $(mandir)/man2/,$(filter %.2,$(libretools.out.mans))) \
+ $(addprefix $(mandir)/man3/,$(filter %.3,$(libretools.out.mans))) \
+ $(addprefix $(mandir)/man4/,$(filter %.4,$(libretools.out.mans))) \
+ $(addprefix $(mandir)/man5/,$(filter %.5,$(libretools.out.mans))) \
+ $(addprefix $(mandir)/man6/,$(filter %.6,$(libretools.out.mans))) \
+ $(addprefix $(mandir)/man7/,$(filter %.7,$(libretools.out.mans))) \
+ $(addprefix $(mandir)/man8/,$(filter %.8,$(libretools.out.mans))))
files.out.int += *.pot *.ugly *.rej *.orig
files.out.all += $(foreach pkg,$(filter-out all,$(files.groups)),$(files.out.$(pkg)))
diff --git a/config.mk b/config.mk
index 882e2e9..fbd0ec5 100644
--- a/config.mk
+++ b/config.mk
@@ -29,6 +29,8 @@ sysconfdir = /etc
mandir = $(datarootdir)/man
devtoolsdir = $(call abspath,$(topsrcdir)/../devtools-par)
+
+enable_manpages = t
RONNFLAGS = --manual='libretools Manual' --organization='Parabola'
TESTENVFLAGS ?=